Сервер Apache 2.2.11 - правила позволяющие избежать ошибок. Тестирование Apache 2.2.11 HTTP Server. Главным критерием корректности внесенных изменений в файлы конфигурации сервера Apache 2.2.11 является, после нажатия на ярлык, см. создание ярлыков появление, на несколько секунд, чистого окна DOS. Если появится окно DOS - Restart (на 30 секунд) с сообщением об ошибке, нужно определить - в каком файле она произошла. В данном примере в главный файл конфигурации сервера Apache2.2.9 - C:/Program Files/Apache Software Foundation/Apache2.2 /conf/httpd.conf - в строку 27 была внесена запись "123". О чем и сообщил, при перезагрузке, сервер Apache. Syntax error on line 27 of C:/Program Files/Apache Software Foundation/Apache2.2 /conf/httpd.conf: Invalid command '123', perhaps misspelled or defined by a module not included in the server configuration Note the errors or messages above, and press the <ESC> key to exit. 26... Изменения в файлы конфигурации обычно вводятся в программе 'Блокнот'. Не забывайте их сохранить и перезагрузить сервер Apache 2.2.11. Нужно это потому, что сервер читает файлы конфигурации, только при включение компьютера. Иначе вы не увидите того, чего ожидали, внося изменения. Но это не самое неприятное. Не перезапустив службу Apache 2.2, после внесения ошибочных изменений в файлы конфигурации, и выключив компьютер вы, при повторном его включении, можете увидеть следующее сообщение - сбой, по крайней мере, в одной службе или драйвере при запуске системы. Получение подобных сообщений, не имеющих достаточного опыта пользователей, приводит в замешательство и к последующим неадекватным ситуации действиям, вплоть до переустановки OS. Если ошибка вызвана сбоем службы Apache 2.2 и вы имеете резервные копии файлов конфигурации, то для устранения данной ошибки, достаточно заменить конфигурационные файлы на рабочие. Не забудьте, перед этим, остановить службу Apache. (Пуск - Администрирование - Службы - выделить Apache/2.2.9 и нажать пункт - Остановить службу.) Просмотрев журнал событий, пройдя: Пуск - Администрирование - Просмотр событий, «Administrative Tools» - «Event Viewer» нажав, для выяснения причин ошибки, правую кнопку мыши и в выбрав, в контекстном меню , пункт - Свойства. Определив, что сбой произошел в службе Apache 2.2. В данном примере легко определить причину вызвавшую ошибку. После Restsrt'а - можно локализовать до строки. В большинстве случаев это не так очевидно. Вы можете выбрать два варианта дальнейших действий: Тестировать файлы конфигурации сервера Apache 2.2.11. Заменить файлы конфигурации сервера на резервные. Очевидно, что второй вариант предпочтительней. Вот для чего нужен дневник. Сервер Apache 2.2.11 - резервирование файлов конфигурации. Создайте каталог Дневник с подкаталогами: месяц - день - время. разместив его в удобном для вас месте, например, C:\Дневник\Январь\01\14 20\ И, до внесения изменений в файлы конфигурации и главного сайта сервера Apache 2.2.11, сохраняйте (предварительно проверенные) их копии в дневнике. Это позволит вам в любой момент вернуться к рабочей и проверенной версии главного сайта и сервера Apache 2.2.11. Резервировать, для того, чтобы быть полностью уверенным в работоспособности сервера Apache, необходимо: полностью каталог conf находящийся в C:\Program Files\Apache Software Foundation\Apache2.2\ файл hosts находящийся в C:\WINDOWS\system32\drivers\etc\ Apache - правила позволяющие избежать ошибок при конфигурировании сервера. Всегда имейте резервные копии рабочих версий файлов конфигурации сервера Apache 2.2.11 HTTP Не забывайте сохранить файлы конфигурации после внесения изменений (бывает, при нескольких открытых программах) и перезапустить сервер Apache 2.2.11. нажав на ярлык и выбрав пункт Restart или пройдя путь - Пуск - Все программы - Apache 2.2.11 HTTP Server - Control Apache Server - Restart. Перед выключением компьютера - перезапустите службу Apache 2.2. Источник (с) avege.ru
На статью не тянет. Чет она вообще какие-то элементарные вещи объясняет, заметка эта. Но может кому и пригодится..